当前位置:
首页 > 网络赚钱从0做起 > 易语言教程收集 > 易语言超级列表框之检查框常用易语言源码

易语言超级列表框之检查框常用易语言源码

易语言超级列表框之检查框常用易语言源码

1:超级列表框之检查框导入默认全选

首先确保超级列表框的属性 有一项      是否有检查框,将它设为真,否则无效!

     超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 010))


2:超级列表框之检查框按钮全选

.版本 2

.支持库 iext 

.子程序 _按钮_全选_被单击, , , 

.局部变量 i, 整数型

.计次循环首 (超级列表框1.取表项数 (), i)

    超级列表框1.置状态图片 (i - 11)

.计次循环尾 ()


3:超级列表框之检查框按钮反选

.版本 2

.支持库 iext

.子程序 _按钮_反选_被单击, , ,

.局部变量 i, 整数型

.计次循环首 (超级列表框1.取表项数 (), i)

    超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 010))

.计次循环尾 ()


4:超级列表框之检查框按钮删除选中

.版本 2

.支持库 iext

.子程序 _按钮_删除选中_被单击, , , 

.局部变量 i, 整数型

.计次循环首 (超级列表框1.取表项数 (), ) 

    i = i + 1

    .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)

        超级列表框1.删除表项 (i - 1)

        i = i - 1

    .如果真结束

.计次循环尾 ()


客服QQ:5409-88887

 哒哒网络工作室